Agency/Insured/Diamond - Web Portal Issue
Incident Report for producersnational
Resolved
This incident has been resolved.
Posted May 31, 2023 - 21:01 CDT
Investigating
We are currently experiencing issues with processing payments regarding a message stating, "This payment exceeds the transaction limit," We are sorry for the inconvenience, and we are working on a fix to have the system restored soon!

Thank you!
Posted May 31, 2023 - 12:56 CDT
This incident affected: AgencyPortal, InsuredPortal, and API.