Ring Central Contact Center Issue/Outage
Incident Report for producersnational
Resolved
This incident has been resolved.
Posted Mar 19, 2024 - 18:21 CDT
Update
We are continuing to investigate this issue.
Posted Mar 19, 2024 - 18:19 CDT
Investigating
We are currently investigating an issue with the contact center for Ring Central.
Posted Mar 19, 2024 - 16:07 CDT
This incident affected: PhoneLines.