Agency/Insured/Diamond - Web Portal Issue
Incident Report for producersnational
Resolved
This incident has been resolved.
Posted May 24, 2022 - 20:05 CDT
Update
We are continuing to investigate this issue.
Posted May 24, 2022 - 14:41 CDT
Investigating
We are currently experiencing issues on the Agency Website Portal, Insured Website Portal, and the Employee Diamond Portal system.

DocuSign system is currently having issues on there end and are unable to sign documents.

We are sorry for the inconvenience and we are hoping to have the system restored soon!

Thank you!
Posted May 24, 2022 - 14:41 CDT
This incident affected: AgencyPortal, InsuredPortal, and API.