Billing/Credit Card Outage
Incident Report for producersnational
Resolved
Redmountain, CCC, Credit Cards, and Docusign are back up.
Posted Jul 28, 2021 - 17:24 CDT
Update
We are continuing to investigate this issue.
Posted Jul 28, 2021 - 16:58 CDT
Update
Affects REDMOUNTAIN, CCC, Credit Cards, Docusign, and quoting portals.
Posted Jul 28, 2021 - 16:58 CDT
Investigating
Issue taking credit card payments, affecting Employee and Agency portal.
Posted Jul 28, 2021 - 16:23 CDT
This incident affected: AgencyPortal and InsuredPortal.